Автор Тема: Проблема с раскладкой и кодировками  (Прочитано 5709 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Mati_maniak

  • *
  • Сообщений: 14
  • Karma: +0/-0
Итак есть 2 проблемы:

1. В КСС выбрал 2 раскладки (русскую и английскую), но они никак не хотят переключаться с клавиатуры - приходится тыкать мышкой по значку утилитки в трее...
2. В том же КСС в заголовке окна вместо русских букв видны знаки вопроса, а также теже знаки вопроса вместо русских символов в некоторый программах, например в Kopete...

mc Панама

  • *
  • Сообщений: 4
  • Karma: +0/-0
(Нет темы)
« Ответ #1 : 28 Февраля 2006, 06:42 »
отредактируй в xorg.conf раздел InputDevice примерно вот так:

Section "InputDevice"
    Identifier "Keyboard1"
    Driver "kbd"
    Option "AutoRepeat" "500 30"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc104"
    Option "XkbLayout" "us,ru" #добавишь два языка
    Option "XkbOptions" "grp:ctrl_shift_toggle,grp_led:scroll" #переключение при нажатии ctrl+shift
EndSection


а знаки вопроса - это наверное нужно кодировку поменять...

Mati_maniak

  • *
  • Сообщений: 14
  • Karma: +0/-0
(Нет темы)
« Ответ #2 : 28 Февраля 2006, 07:52 »
Огромное спасибо... Всё идеально работает... :D

mc Панама

  • *
  • Сообщений: 4
  • Karma: +0/-0
(Нет темы)
« Ответ #3 : 28 Февраля 2006, 09:04 »
пожалуйста. Всегда рад помочь :lol:

Mati_maniak

  • *
  • Сообщений: 14
  • Karma: +0/-0
(Нет темы)
« Ответ #4 : 28 Февраля 2006, 09:06 »
Вот ещё бы знать где в системе кодировку поменять... :shock: