Автор Тема: Звук на ноуте в Дебиан Сарге???  (Прочитано 3540 раз)

0 Пользователей и 1 Гость просматривают эту тему.

arty_m

  • *
  • Сообщений: 135
  • Karma: +0/-0
Звук на ноуте в Дебиан Сарге???
« : 12 Апреля 2007, 05:13 »
Ну вот я и рискнул поставить на свой ноут - второй Осью - Дебиан Сарге...
Все бы хорошо, но звуковуха не определилась,
Попытался установить ALSA,
но при установке она ругнулась что нет исходника ядра...
Что посоветуете делать для "озвучки"?
Помнится что кто-то упоминал что пользуется этой Осью...
Слакс 11 - прекрасно звучит...

kostiak

  • *
  • Сообщений: 140
  • Karma: +0/-0
(Нет темы)
« Ответ #1 : 12 Апреля 2007, 10:39 »
А чё за звуковуха (lspci в помощь)? Ещё можно глянуть в Slax'е какие звуковые модули подгружены (lsmod | grep snd) и попробовать подгрузить соответствующие. И ещё нескромный вопрос, а почему Sarge? :) Я к тому, что 8 апреля уже Etch вышел, если пугает слово "testing" :), на ноут его ставить предпочтительнее, ну или просто обновиться до него, если возможности позволяют.

kostiak

  • *
  • Сообщений: 140
  • Karma: +0/-0
Re: Звук на ноуте в Дебиан Сарге???
« Ответ #2 : 12 Апреля 2007, 10:48 »
Цитата: "arty_m"
Попытался установить ALSA,
но при установке она ругнулась что нет исходника ядра...

А каким образом устанавливали? Не похоже, что при помощи "apt-get install alsa-base" :)

arty_m

  • *
  • Сообщений: 135
  • Karma: +0/-0
(Нет темы)
« Ответ #3 : 12 Апреля 2007, 03:39 »
Сарге - по причине того что есть под рукой. Оказался двухдисковый дистрибутив с журнала "ЧИП"...
Ноут у меня капризный, многое почему-то не встает и не запускается даже... (Удавалось Слакс11, Кнопп3.7 с ядрами 2.4)
Звуковуха Card: HDA ATI SB
Chip: Realtek ALC861

Хм... А куда надо новую Алсу класть и в каком виде, чтобы ее подцепить на "apt-get install alsa-base" ?
И кстати то же самое наверно можно с видеокартой проделать...
У меня есть драйвера с официального сайта АТИ:
[list=]fglrx_6_8_0-8.35.5-1.i386.rpm  - ATI-X.Org
[/list][list=]fglrx_4_3_0-8.35.5-1.i386.rpm XFree86 4.3 [/list]
и [list=]ati-driver-installer-8.35.5-x86.x86_64.run[/list]

Что с ними можно сделать (вернее как)?

arty_m

  • *
  • Сообщений: 135
  • Karma: +0/-0
(Нет темы)
« Ответ #4 : 12 Апреля 2007, 04:15 »
Может чем-то поможет:
debian:~# lspci
0000:00:00.0 Host bridge: ATI Technologies Inc: Unknown device 5a31 (rev 01)
0000:00:01.0 PCI bridge: ATI Technologies Inc: Unknown device 5a3f
0000:00:13.0 USB Controller: ATI Technologies Inc: Unknown device 4374 (rev 80)
0000:00:13.1 USB Controller: ATI Technologies Inc: Unknown device 4375 (rev 80)
0000:00:13.2 USB Controller: ATI Technologies Inc: Unknown device 4373 (rev 80)
0000:00:14.0 SMBus: ATI Technologies Inc: Unknown device 4372 (rev 82)
0000:00:14.1 IDE interface: ATI Technologies Inc: Unknown device 4376 (rev 80)
0000:00:14.2 0403: ATI Technologies Inc: Unknown device 437b (rev 01)
0000:00:14.3 ISA bridge: ATI Technologies Inc: Unknown device 4377 (rev 80)
0000:00:14.4 PCI bridge: ATI Technologies Inc: Unknown device 4371 (rev 80)
0000:01:05.0 VGA compatible controller: ATI Technologies Inc: Unknown device 5a6 2
0000:02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C /8139C+ (rev 10)
0000:02:01.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev 8d)
0000:02:01.1 0805: Ricoh Co Ltd: Unknown device 0822 (rev 13)
0000:02:01.2 System peripheral: Ricoh Co Ltd: Unknown device 0592 (rev 04)
debian:~#

И ещеdebian:~# apt-get install alsa-base
Чтение списков пакетов... Готово
Построение дерева зависимостей... Готово
Пакет alsa-base недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list
E: Для пакета alsa-base не найдены кандидаты на установку
debian:~#

Я в растерянности...

kostiak

  • *
  • Сообщений: 140
  • Karma: +0/-0
(Нет темы)
« Ответ #5 : 12 Апреля 2007, 07:35 »
Цитата: "arty_m"
Я в растерянности...

Ясно, sources.list не настроен:
$ ssh sarge
$ cat /etc/debian_version
3.1
$ apt-cache policy alsa-base
alsa-base:
  Installed: (none)
  Candidate: 1.0.8-7
  Version Table:
     1.0.8-7 0
        500 http://debian.balt.net stable/main Packages

Покажи вывод "cat /etc/apt/sources.list", "apt-cache policy alsa-base" и "uname -a"