Автор Тема: Видеокарта Asus X1650 AGP - кто запускал, и с каким бубном?  (Прочитано 3457 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Lotos

  • *
  • Сообщений: 27
  • Karma: +0/-0
Доброго времени суток!
Собственно, карта работала в режиме "vesa". Ставлю все примочки fglrx-driver, -src, запускаю инсталлятор ххх.run - все проходит на ура, прописываю в xorg.conf, но без результата. Сервер запускается, но при запуске ATI Catalyst Contol Center сообщается, что драйвер или не установлен, или работает неправильно. Установите драйвер соответствующий вашему устройству...
Первый раз сервер запустился с искажениями, пришлось возвращать в "vesa".
на
glxinfo | grep direct выдает:
direct rendering: No

И еще при запуске KDE сообщение об остановке работы программы Composite Manager

Кто что подскажет на первый взгляд?
Спасибо!

Lotos

  • *
  • Сообщений: 27
  • Karma: +0/-0
(Нет темы)
« Ответ #1 : 06 Апреля 2008, 12:34 »
Вот листинг xorg'a
для запуска режима 3D была на одном ресурсе рекомендация выставить BusID       "PCI:1:1:0", но после этого иксы не стартуют:

Section "Monitor"
   Identifier   "SyncMaster"
   Option       "DPMS"
EndSection

Section "Monitor"
   Identifier   "aticonfig-Monitor[0]"
   Option       "VendorName" "ATI Proprietary Driver"
   Option       "ModelName" "Generic Autodetecting Monitor"
   Option       "DPMS" "true"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]"
   Driver      "fglrx"
   BusID       "PCI:1:0:0"
EndSection

Section "Screen"
   Identifier "Default Screen"
   Device     "ATI Technologies Inc ATI Default Card"
   Monitor    "SyncMaster"
   DefaultDepth     24
   SubSection "Display"
      Depth     1
      Modes    "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     4
      Modes    "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     8
      Modes    "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     15
      Modes    "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     16
      Modes    "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     24
      Modes    "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]"
   Device     "aticonfig-Device[0]"
   Monitor    "aticonfig-Monitor[0]"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

Section "DRI"
   Mode         0666
EndSection



а Composite Manager - вроде отвечает за поддержку полупрозрачности окон, такой секции нет в xorg.conf и сообщение рекомендует его вписать, или установить xorg >= 6.8... вот после попытки прописки этой секции иксы стали совсем "прозрачными" и с искажениями.

Перезагружаешь иксы - все нормально, входишь в графическом режиме. Ребут системы - вход только в консоль, приходится возвращать сохраненный заранее xorg.conf  (или править имеющийся).

Смотрел на других ресурсах, вроде с этими картами есть проблемы с настройкой.
Debian 4.0, xorg 7.1

rain

  • Global Moderator
  • *****
  • Сообщений: 663
  • Karma: +10/-0
(Нет темы)
« Ответ #2 : 09 Апреля 2008, 02:49 »
Посмотри с логах установщика драйверов, действительно ли все нормально поставилось. Кроме того, посмотри в логах иксов на что ругается при подгрузке модуля.
"BusID "PCI:1:0:0" " - не обязательно на твоей системе это будет так же.
Composite пока не трогай, настрой хотя бы 3D
Registered Linux User # 377068
Аз есмь линуксоид <img src=\"{SMILIES_PATH}/wink.gif\" alt=\";)\" title=\"Wink\" />
Присоединяемся к акции массового перехода на Jabber -
самую современную сеть обмена мгновенными сообщениями!

Меня

Lotos

  • *
  • Сообщений: 27
  • Karma: +0/-0
(Нет темы)
« Ответ #3 : 11 Апреля 2008, 01:39 »
Спасибо!
Все вроде нормально, вот
fglrx-install.log
----------------------------
[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kernel module now.
ATI module generator V 2.0
==========================
initializing...
cleaning...
patching 'highmem.h'...
assuming new VMA API since we do have kernel 2.6.x...
 Assuming default VMAP API
 Assuming default munmap API
doing Makefile based build for kernel 2.6.x and higher
make -C /lib/modules/2.6.18-4-686/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.18-4-686'
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
  LD [M]  /lib/modules/fglrx/build_mod/2.6.x/fglrx.o
  Building modules, stage 2.
  MODPOST
  CC      /lib/modules/fglrx/build_mod/2.6.x/fglrx.mod.o
  LD [M]  /lib/modules/fglrx/build_mod/2.6.x/fglrx.ko
make[1]: Leaving directory `/usr/src/linux-headers-2.6.18-4-686'
build succeeded with return value 0
duplicating results into driver repository...
done.
==============================
- recreating module dependency list
- trying a sample load of the kernel modules
done.
видимо в иксах дело, посмотрю.

Lotos

  • *
  • Сообщений: 27
  • Karma: +0/-0
(Нет темы)
« Ответ #4 : 09 Июня 2008, 10:17 »
С этой картой (ATI Radeon X1650 у меня пока не получилось, как только не пробовал, и с помощью Envy и вручную...
Если у кого будут положительные результаты, поделитесь.
Буду пробовать еще, но возможно будет неудачно и с другими версиями драйвера (экспериментировал с последней)... Если удастся, то опишу процесс.
А пока перешел на PCI-Е с картой на GF 8600GT - установилась без проблем через шелл и отлично. Правда сначала попробовал через Envy - не получилось (ранее ставил систему на более древней карточке NVidia - без проблем), xorg.conf скрипт переписал нормально, но иксы не запустились, видимо по умолчанию скрипт качал старые версии драйверов.
При установке системы карта не определилась.